Contact US

Fill out the form and we’ll get back to you asap.

FAQs

What are the requirements to use Divi Sumo?

You need to have the latest version of Divi Theme on your website. Divi Sumo is built on-top of Divi API. This plugin requires Divi Theme, Extra Theme or Divi Builder plugin to work..

Does it work with latest Divi visual builder?

Divi Sumo is built with the latest Divi API and is 100% compatible and works great with the latest Divi visual builder.

Can I use Divi Sumo on client websites?

Absolutely! You can definitely use Divi Sumo on yours as well as your client’s websites.